ACM | FatMouse' Trade

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

输入格式:

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

输出格式:

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

输入样例:

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

输出样例:

13.333
31.500

错误代码示例:

#include<stdio.h>
int main(){
    int M,N;
    scanf("%d%d",&M,&N);
    int J[100]; //回报
    int F[100]; //付出
    double s[100];
    while(M!=-1 && N!=-1){
        for(int i=0;i<N;i++){
            scanf("%d%d",J+i,F+i);
            s[i]=1.0*J[i]/F[i];
        }
        double max;
        int cur;
        double ans=0.0;
        while(M>0){
            max=0.0;
            cur=0;
            for(int i=0;i<N;i++){ //找到回报率最大的位置
                if(s[i]>max){
                    max=s[i];
                    cur=i;
                }
            }
            s[cur]=0.0;
            if(M>=F[cur]){
                M-=F[cur];
                ans+=J[cur];
            }else{
                ans+=J[cur]*(1.0*M/F[cur]);
                M=0;
            }
            //printf("*%d*%lf*\n",cur,ans);  DEBUG
        }
        printf("%.3lf\n",ans);
        scanf("%d%d",&M,&N);
    }
    return 0;
}

正确代码示例:

#include<stdio.h>
int main(){
    int M,N;
    scanf("%d%d",&M,&N);
    int J[1001]; //回报
    int F[1001]; //付出
    double s[1001];
    while(M!=-1 && N!=-1){
        for(int i=0;i<N;i++){
            scanf("%d%d",J+i,F+i);
            s[i]=1.0*J[i]/F[i];
        }
        double max;
        int cur;
        double ans=0.0;
        int items=N;
        while(M>0 && N>0){
            max=0.0;
            cur=0;
            for(int i=0;i<N;i++){ //找到回报率最大的位置
                if(s[i]>max){
                    max=s[i];
                    cur=i;
                }
            }
            s[cur]=0.0;
            if(M>=F[cur]){
                M-=F[cur];
                ans+=J[cur];
                items--;
            }else{
                ans+=J[cur]*(1.0*M/F[cur]);
                M=0;
            }
            //printf("*%d*%lf*\n",cur,ans);  DEBUG
        }
        printf("%.3lf\n",ans);
        scanf("%d%d",&M,&N);
    }
    return 0;
}

ACM | FatMouse' Trade
https://acm.nanyan.cc/posts/628c.html
作者
nanyan
发布于
2023年10月17日
许可协议